Archiware P5 Version 5.4

Find all relevant information and links

New Features

Archive to the Cloud

Cloud storage is a cost-effective and flexible alternative for businesses, saving hardware and administration cost. Plus, it grows with your requirements - additional TBs of storage space are easily added.

Archiware P5 version 5.4 now offers "Cloud Storage" as an option for the archive target, the third option next to the existing disk and tape targets (see screenshot below). Simply chose the new target when setting up your Archive plan.

In the P5 Archive Overview, the use of available cloud storage (according to the license) is shown for better insight (see screenshot below).

To use cloud storage as an archive target, a P5 Archive Cloud Enabler license is required. Once this license is registered, the option to configure cloud services is activated in the user interface. Archiware P5 version 5.4 supports Amazon S3 cloud services only. In future versions, more cloud services and providers will be added continously.

 The Cloud integration is currently only available for Mac. Other platforms will be added in future versions.

Screenshot P5 Archive 5.4 Cloud Storage Usage.png

Cloud storage as target option and cloud storage usage

Preview Creation using FFmpeg & ImageMagick

To give users more options when creating proxy videos or image previews, Archiware P5 version 5.4 now offers a direct integration with FFmpeg and ImageMagick. It is now easy to create low-resolution, full-length previews for video: simply select resolution and data rate for video and audio (or resolution for images).

The configuration of both tools can now be done within the settings of P5 Archive, no scripting required.

For increased browser compatibilty and performance, the display method for previews has been changed to HTML5.

Screenshot FFmpeg ImageMagick

Configuration examples for FFmpeg and ImageMagick

Synology NAS integration (as of 5.3.3)

From Version 5.3.3, Archiware P5 supports Synology NAS devices without restrictions. Data from Synology devices is stored in a platform neutral format including user authorisations - identical to all other supported platforms.

Synology NAS can serve as a data source or target for P5 Synchronize, P5 Backup and P5 Archive. The Archiware P5 application can now be installed on the Synology NAS itself.

Thanks to the snapshot capability of the DSM platform, powerful enterprise Synology NAS devices can also be used as repository for Backup2Go. This setup opens the possibility of introducing a professional data security solution at an affordable price point.

Find the new installation package for Synology NAS devices on the Download page. There is also a step-by-step installation guide with a few tips in this blog post.

Restore links / Source selection in P5 Archive

To support co-operative workflows, P5 Archive now offers the possibility to send a link to an asset via e-mail. The recipient just clicks the link to watch the preview, view and edit metadata, restore or simply approve the choice of video for an edit.

Another simplification in P5 Archive has been implemented in the source selection: The tree structure now immediately displays the user directory and all mounted volumes, saving the user several clicks when selecting files or folders to archive from their file system.

Data integrity checks / List display / OS support

The data integrity check options have been expanded for Archive to disk and tape. The following checksum types are available: MD5, SHA-224, SHA-256, SHA-384, SHA-512. Additionally, compare content can be selected as verification method.

For a comprehensive overview of Backup and Synchronize jobs, the Backup/Synchronize plan lists now display the next scheduled run.

Lastly, as of version 5.4, Archiware P5 officially supports macOS 10.12 Sierra and Windows Server 2016.

 

Requirements & Compatibilities

Requirements - Archiware P5 Version 5.4

Operating System Requirements

Mac OS X Intel 10.6 – 10.13
Windows

Server 2008R2, 2012R1/R2, 2016
Windows 7, 8, 8.1, 10 (64-Bit)
Please read before installing!

Linux
  • Kernel 2.6.4+ (x86 64-Bit)
  • For FS-events with inotify, Kernel 2.6.13+
  • As Backup2Go Server: Btrfs 0.19+
Solaris Sparc Solaris 2.8+, x86 Solaris 2.10+.
Note:
Language package Unicode UTF-8 required

FreeBSD

9.2, 9.3, 10.1 - 10.3 (64-Bit)

Synology

DSM operating system 5.2+ (Intel x86 64-Bit)
(as of P5 Version 5.3.3)

Virtualization x86 – VMware, Parallels, Xen, Hyper-V

Hardware requirements

Memory 1 GB+
Hard disk 1 GB for Installation + variable
(for backup/archive indexes)

 

Browser Requirements

Safari 5.1 +
Firefox 3.5+
Chrome 4+
Internet Explorer 10+

Compatibilites - Archiware P5 Version 5.4

Supported Tape Technologies

  • LTO-1, LTO-2, LTO-3, LTO-4, LTO-5, LTO-6, LTO-7
  • S-AIT 1, 2, 3, 4
  • AIT 1, 2, 3, 4, 5, 6
  • DLT4000-8000
  • SDLT220-600
  • DLT-S4
  • VXA (on request)
  • 8mm
  • DAT

Disk Storage

  • Direct attached storage (DAS)
  • Storage area network (SAN)
  • Synology NAS (as of P5 Version 5.3.3)
  • XSAN
  • RAID
  • MetaSAN 4.5.0.0 (Windows/Linux supported from 4.6.0.0)
  • Removable Disk (RDX QuikStor)
  • HyperFS

Proprietary File Systems

  • Helios (UB, UB+, UB2, UB64)
  • Xinet V14
  • Netatalk 2

Supported Interfaces

  • SAS
  • SCSI
  • iSCSI
  • FibreChannel
  • Firewire
  • USB
  • SATA
  • eSATA
  • Thunderbolt

3rd Party Integrations

  • axle
  • Final Cut Server
  • Canto Cumulus
  • CANTEMO
  • CatDV
  • empress eMAM
  • FocalPoint Server
  • Metus
  • Xinet

Supported Tape Library Vendors

  • BDT
  • Dell
  • HPE
  • IBM
  • NEC
  • Oracle/StorageTek
  • Overland
  • Qualstar
  • Quantum
  • Sony (AIT)
  • Spectra Logic
  • Tandberg Data

Supported Hardware Manufacturers

  • Accusys
  • Apple
  • DDP
  • Dell
  • Drobo (as a disk)
  • HPE
  • IBM
  • LaCie
  • mLogic
  • NEC
  • Netgear
  • Object Matrix
  • Overland
  • Promise
  • Qualstar
  • Quantum
  • Samsung
  • Scale Logic
  • Sonnet
  • Sony (AIT)
  • Spectra Logic
  • Sun/Oracle
  • Synology (as of P5 Version 5.3.3)
  • Tandberg Data

Upgrade FAQ

Please read these FAQ carefully before upgrading to Version 5.4!

To download Archiware P5 Version 5.4 for an Upgrade, go to the Download section.

Updating from Archiware P4

Files stored with P4 can be restored through P5, but only with reduced functionality and without search capabilities.

P5 Backup: After having upgraded to P5 Backup, a full backup run is required.
Please be sure to schedule backup time and capacity accordingly.

P5 Archive: P5 Archive requires a conversion of the P4 archive index. To do so, each archive index has to be converted within the administration section of P5. Depending on the size of the index as well as computing power, this process can take anything between minutes and hours.

For more details, please read the P5 Upgrade Guide.

FAQ - Updating to Archiware P5 Version 5.4

What is new in Archiware P5 Version 5.4?

Version 5.4 is an update release. The feature set is identical to Version 5.3 for the most part.
For more information about Version 5.4, please refer to the New Features page.

Note: When updating to P5 5.4, the 32-Bit version is automatically replaced by the 64-Bit version.

Which PresSTORE or Archiware P5 versions can directly update to Version 5.4?
  • Only Version 5.0.x, 5.1.x, 5.2.x and 5.3.x can be updated directly to Version 5.4.
  • Version 4.4 need to be updated to Version 5.1 first.
    For more details please refer to Upgrade FAQ 5.1.
  • Older versions need to be updated to Version 4.4.x. first.
    For more details please refer to Upgrade FAQ 4.4.
Who is entitled to an Update free of charge?

The update is free of charge for all customers who:

  • purchased or registered P5 after November 28th, 2015 or
  • had active Software Maintenance on November 29th, 2016.

 
Validity of the Software Maintenance Agreements can be verified in the Archiware Portal.

How much does it cost to update an installation when Software Maintenance is expired?

Updates are available through the Archiware Software Maintenance. For all licenses that ran out of maintenance, a reactivation of Software Maintenance is possible. It covers two major aspects: access to the latest software version and access to manufacturer support. Prices depend on how long the maintenance is expired:

  • Expiration <1 year:   35% of the license price according to the current price list
  • Expiration <2 years: 60% of the license price according to the current price list
  • Expiration <3 years: 70% of the license price according to the current price list


The reactivated maintenance is valid for 12 months, starting on the 1st of the month following the Archiware invoice date.

For more details about Archiware Software Maintenance & Support please refer to the Maintenance & Support.

Where can I get a quote for reactivation of Archiware Software Maintenance?

In order to receive a Software Maintenance reactivation quote, please contact your local reseller or request one through the Archiware Portal.

Which preparations should be made before the Update?
  • Make sure you meet the System Requirements.
  • Make sure you are eligible for the required license (point 3/4) or request a corresponding quote (point 5).
  • For security purposes, please make a copy of the installation directory!
Do I need new license keys for the Update and where can I get them?

Since the introduction of Version 4.3, the maintenance expiration date is part of the license key. All installations with an up-to-date key and a valid Software Update Agreement do not need a new license key.

Installations without an up-to-date key have to request one through the Archiware Portal.

What are the system requirements for P5 Version 5.4?

On this dedicated page, you will all information about System Requirements for P5 Version 5.4.

Which features of previous version are no longer available in P5 Version 5.4?
  • WingFS/P5 Synchronize integration

 
Note from the previous version: In P5 Version 5.3, P5 notifications on the screen using Growl, the
Mac OS X Notification Center or Windows Desktop Notifications are no longer supported.

All P5 notifications and protocols can now be sent and received via e-mail.

Preview creation using Quicktime is no longer supported for Windows since the product was discontinued by Apple. Products such as FFMPEG or ImageMagick can be used as an alternative.

What technical effort is required for the Update?

An update from Version 5.x installation is comparable to a new installation.

The installer automatically detects an existing version and executes all necessary changes in the application and its configuration. Please check if it might be necessary to take precautions for a downgrade (see point 13). For security reasons, please create a copy of your installation directory.

Important Note for updating from 5.2 and previous releases: In some rare cases, a full backup may be necessary for P5 Backup. Therefore, the first backup after the upgrade will require the appropriate amount of time and backup capacity. The reason for this is that any missing drive information is mandatory in Version 5.4.

Do all clients/agents have to be updated to P5 Version 5.4 as well?

Yes, Version 5.4 has to be installed on all servers, workstations and virtual server agents.

Will all my settings remain intact when updating?

Yes, all settings remain intact when installing P5 Version 5.4.

Is it possible to downgrade to a previous version after updating to P5 Version 5.4?

After updating from Version 5.x:

For P5 Backup and P5 Archive, a downgrade is not possible.

Note: please refer to the necessary preparations described in point 6.
In case it is necessary to re-activate Version 5.x, this can only be done through a new installation and a subsequent restore of the configuration from a security copy made previously.

For P5 Synchronize and P5 Backup2Go, a downgrade back is possible with the following consequence:

  • All P5 Server and Workstation Agents have to be downgraded as well.

 

After upgrading from Version 4.4:

For P5 Backup and P5 Archive, a downgrade is not possible.

Note: please refer to the necessary preparations described in point 6.
In case it is necessary to re-activate Version 4.4, this can only be done through a new installation and a subsequent restore of the configuration from a security copy made previously.

Download

ARCHIWARE P5 Version 5.4.4
MAC OS X

Intel 10.6 - 10.12

611 MB
Windows

Server 2008R2, 2012R1/R2, 2016 Windows 7, 8, 8.1, 10 (64-Bit)

101 MB
Linux

Kernel 2.6.4+ (x86)

152 MB
FreeBSD

9.2, 9.3, 10.1 - 10.3 (64-Bit)

152 MB
Solaris

Sparc Solaris 2.8+
x86 Solaris 2.10+

152 MB
Synology

DSM 5.2+
(Intel x86 64-Bit CPU only!)

52 MB

For a successful installation:

  1. Read the License Agreement.
  2. Request a trial license within P5 and register your license as shown in the installation video.
  3. Unpack the compressed (.zip) file in a folder with at least 1 GB of free space.
  4. Follow the instructions in the README file to install.

P5 Version Archive

Version 5.4

Information and Downloads for Version 5.4

Version 5.3

Information and Downloads for P5 Version 5.3

Version 5.2

Information and Downloads for P5 Version 5.2

Version 5.1

Information and Downloads for P5 Version 5.1

Version 5.0

Version 5.0 is no longer available.
It has been replaced by compulsory upgrade Version 5.1 which is identical in functionality.

Version 4.4

Information and Downloads for PresSTORE P4 Version 4.4